Why are WhatsApp messages not getting delivered to customers?
Your WhatsApp messages are not getting delivered to customers because the recipient is an invalid user on WhatsApp or other Meta restrictions for WhatsApp.
Cause
- The recipient's phone number is not a WhatsApp phone number.
- Recipient has not accepted WhatsApp's new Terms of Service and Privacy Policy.
- The recipient is using an old, unsupported version of WhatsApp on their phone.
- Meta blocked the delivery of Marketing template messages to the recipient. Meta imposes an unspecified limit to how many marketing messages WhatsApp users can receive at a given time. This limit is based on the number of marketing conversations opened with a user from any business, and is not related to the interactions between the user and your business.
Resolution
- Confirm with the recipient that they have accepted Meta's latest Terms of Service for WhatsApp. If they have not, then send them this link https://wa.me/tos/20210210 to accept the latest WhatsApp Terms of Service.
- Confirm with the recipient that they have an active WhatsApp phone number
- Confirm with the recipient that they have the latest WhatsApp version on their phone.