Why do I see a transaction sync failure in Peakflo even though the bill is paid and transaction entry exists in Jurnal?

Cause:

The error shows, Request failed with status code 422: …. Transaction Error Couldn't find TransactionLine with ID=XXX for PurchaseInvoice with ID=YYY in Peakflo. 

This error occurs when a request to sync data fails with a status code 422, indicating a transaction error. This typically happens when a bill is paid through Jurnal, and the corresponding transaction line cannot be found for the bill in Peakflo.

Resolution:

To resolve the issue reach out to Peakflo's support team at support@peakflo.co and we will help you verify the details and complete the sync with Jurnal.