What to do for the error message "Sync Failed - No WHT mapping found in external config" when syncing a bill?

Cause:

You encountered the error message: Sync Failed - No WHT mapping found in external config for PPh 23

This error occurs when there is no Withholding Tax (WHT) mapping in Peakflo that aligns with the WHT configuration in your accounting software (e.g., NetSuite). Essentially, the WHT required for the transaction is present in your ERP but hasn't been mapped in Peakflo.

Resolution: 

1. Identify Missing WHTs:

Contact your accounting team or refer to the accounting software’s WHT list to identify any WHT codes that exist there but are missing in Peakflo.

2. Add Missing WHTs in Peakflo:

Provide the list of missing WHT codes to our support team at support@peakflo.co. We will add these WHTs in Peakflo based on the country-specific requirements.

For detailed mapping steps, please check out the article "How are withholding tax (WHT) synced between NetSuite and Peakflo?"


3. Refresh WHT Mapping in Peakflo:

After the WHTs have been added in Peakflo, follow these steps to refresh the mappings:

  • Go to Settings > Integrations.

  • Select the respective accounting software (e.g., NetSuite).

  • In the Refresh dropdown, click on WHTs.

  • Wait for 30-40 minutes for the refresh to complete.