How to fix Xero error "Invoice not of valid status for modification"
Is your bill stuck in "Sync in Progress" status for a long time? It could be because there's an error in your accounting software that delays the data sync in Peakflo.
As a result, the bill in sync progress can't be moved to draft.
Worry not, let's see how we can fix this problem.
Cause:
This error appears when the user is syncing an invoice that is already paid in Xero.
Resolutions:
- In Xero, remove the payment associated with the bill.
- In Peakflo, go to the Accounting section and under Transactions, find the bill with this error (you can sort by dates to navigate easier). Then, re-sync the bill.
If the issue still persists, contact us at support@peakflo.co.