What should I do when the document date cannot be before the end of year lock date?

Cause:

The error occurs when attempting to sync a document with a date that falls before the end of year lock date set in Xero. The lock date is set to prevent changes to transactions during a past period and can be changed or removed at any time by the Xero advisor user role.

Please check the below article for a better understanding.
Set up or remove lock dates in Xero

Resolution:

To resolve this issue, you have two options:

  1. Change the Bill Date and Resync: Modify the document date to be after the end-of-year lock date in Peakflo. After changing the date, resync the document to update it in Xero.

  2. Open the Period in Xero: Alternatively, you or the Xero advisor can open the period in Xero that corresponds to the document date. This will allow you to make changes to the documents within that period.

Note:
These syncs can be marked as canceled by Peakflo.